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1 Overview 
1.1 Introduction 

This manual explains the steps of electromagnetic field analysis using 

ADVENTURE_Magnetic_on_Windows. 

 

1.2 About ADVENTURE_Magnetic_on_Windows 

ADVENTURE_Magnetic_on_Windows ("AdvMagOnWin") is a software for performing electromagnetic 

field analysis on Windows using ADVENTURE_Magnetic developed in the ADVENTURE project. 

AdvMagOnWin provides functions to import CAD files, generate mesh, set material properties, set boundary 

conditions, decompose domain, set analysis conditions, execute solvers, and create visualization files using 

GUI based on the user interface agent software "ADVENTURE_iAgent".  

Among the analysis functions supported by ADVENTURE_Magnetic Ver. 1.7.0, AdvMagOnWin provides 

non-linear magnetostatic field analysis and time-harmonic eddy current analysis. 

 

1.3 Structure of this Manual 

This manual has the following structure. 

 

Chapter 1 Overview 

In this chapter, the overview of AdvMagOnWin is explained. 

Chapter 2 Non-linear Magnetostatic Analysis 

In this chapter, the steps of non-linear magnetostatic analysis of AdvMagOnWin is explained by 

using the attached sample data. 

Chapter 3 Time-harmonic Eddy Current Analysis 

The procedure of the time-harmonic eddy current analysis by AdvMagOnWin is explained using the 

attached sample data. 

Chapter 4 Useful functions 

In this chapter, utilities provided by AdvMagOnWin. are described. 

 

1.4 Multithreading of Solver  

AdvMagOnWin is equipped with OpenMP multi-thread solver. 

At startup, AdvMagOnWin automatically sets the number of logical processors recognized by Windows 

as the number of threads used by the solver. The number of logical processors can be checked on the 

"Performance" tab of "Task Manager" (Fig. 1.4-1). 

If you want to specify an arbitrary number of threads, edit advmagonwin.bat as follows and start 

AdvMagOnWin. 

Before change: 

set OMP_NUM_THREADS =% NUMBER_OF_PROCESSORS% 

 

After change (example when the number of threads is 4): 

set OMP_NUM_THREADS = 4 
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Fig. 1.4-1 Task Manager 
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2 Non-linear Magnetostatic Analysis 
In this section, we describe the steps of non-linear magnetostatic analysis using sample data attached to 

AdvMagOnWin.  

 

2.1 Model 

The model used in this chapter is a suction magnet that has a space where iron cores with different top and 

bottom shapes face each other. Fig. 2.1-1 shows the cross section of this model. The unit used in Fig. 2.1-1 is 

[mm]. The analysis area is the area obtained by rotating Fig. 2.1-1 around the z axis by 10 degrees. Suppose 

that the forced current density of the coil part flows in the direction perpendicular to the cross section in Fig. 

2.1-1 at 3×107[A/m2]. Magnetic reluctivity of air and coil 𝜈 is 1/(4𝜋)×107[m/H]. The material of annular 

magnet is SS41P, and in this area it shall have non-linearity as shown in Fig. 2.1-2. A list of property values 

is shown in Table 2.1-1. The boundary condition imposes A × n = 0 (where A is the magnetic vector 

potential [Wb / m], n is the unit normal vector of the boundary surface) on all surfaces. 

 

 

 

Table 2.1-1 List of Material Properties 

 Material  Magnetic Reluctivity B-H Characteristic 

Coil 795774.7 - 

Magnetic Material 757.1 - 

air 795774.7 Apply Fig. 2.1-2‘s 

characteristic curve 

 

  

 

Fig. 2.1-1 Cross-sectional View of  

Axisymmetric Model 

 

 

air

annular magnet

co
il

 

Fig. 2.1-2 B-H Curve 
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2.2 Divide Coil Domain 

Since most of the models used in magnetic field analysis consist of multiple materials, AdvMagOnWin 

uses ADVENTURE_TriPatch's surface patch merging program mrpach to combine multiple surface patches 

internally. However, if the shape of the bonded surface between the materials is mismatched, the join may 

fail. In such a case, it may be successful to divide the material into two and then create an IGES file to match 

the shape of the join plane. 

 In the model used this time, the merging surfaces of the materials do not match in the right part of the coil (x 

= 85 mm in Fig. 2.2-1). Therefore, you will divide the coil as shown in Fig. 2.2-1, and make the merging 

surfaces coincide. 

 

 

Fig. 2.2-1 Decomposition of Coil Domain 
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2.3 Starting the Program 

 Double click "advmagonwin_en.bat" in AdvMagOnWin installation folder and start AdvMagOnWin. When 

you start up, a window shown in Fig. 2.3-1 will appear. 

 

 

Fig. 2.3-1 Start Window 

 

Note that if you run advmagonwin_en.bat on Windows 8 / 8.1 / 10, it may show the screen shown in Fig. 

2.3-2. This is a screen to check if there is any danger to the application you tried to start up, and it will be 

shown when you run for the first time. Clicking the "More info" in Fig. 2.3-2 will change to the screen 

shown in Fig. 2.3-3. You can activate AdvMagOnWin by clicking "Run anyway" in Fig. 2.3-3. 

 

 

Fig. 2.3-2 The Screen Shown When Executing the Batch File 
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Fig. 2.3-3 The Screen Shown after Clicking "More info" 

 

Click the "Start" button to show windows in Fig. 2.3-4. 

 

 

Fig. 2.3-4 Initial Windows of AdvMagOnWin 

 

A) Menu Window 

This is a window to call all operations related to analysis. At the bottom of the window, the current 

analysis type is shown. 

B) Message Window 

Advice from the agent (concrete operation method and information on the current operation) is shown. 

C) Operation Flow Window 

Current operation plan is shown. If you click the button next to each item, a summary of the operation 

with that item will be shown in the message window. 

C) Operation Flow Window 

 

B) Message Window 

 

A) Menu Window 
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2.4 Creating Analysis Case 

In order to perform a new analysis, you will create an "analysis case". To create analysis case, select 

"File" -> "Create New Analysis Case" in the menu window. 

 

First of all, you are asked "Save current Analysis?" (Fig. 2.4-1). If you are currently opening the analysis 

case, select "Yes", but here you select "No" because you just started the program. 

 

 

Fig. 2.4-1 Confirmation of Saving Analysis Case 

 

Next, the window in Fig. 2.4-2 appears. Please click "Next". 

 

 

Fig. 2.4-2 Creating Analysis Case 
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Next, the window in Fig. 2.4-3 appears. After confirming that "Electromagnetic Field Analysis" is 

selected as the type of analysis case click "Next". 

 

 

Fig. 2.4-3 Analysis Type 

 

Next, the window in Fig. 2.4-4 appears. After confirming that "Non-linear Magnetostatic" is selected as a 

more detailed genre of the analysis case, please click "Next". 

 

 

Fig. 2.4-4 Analysis Type (Subtype) 

  



ADVENTURE SYSTEM 

11 

 

Next, the window in Fig. 2.4-5 appears. Select "IGES" as the geometry model, "Linear Tetrahedron (Edge 

Element)" as the analysis model, and click "Next". 

 

 

Fig. 2.4-5 Element Type 

 

 An analysis case is created by these operations, and a list of necessary operations is shown in the operation 

flow. The subsequent operations are performed according to the operation flow and the message window. 

Next, we will generate a mesh. 
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2.5 [Preprocess 1] Mesh Generation 

2.5.1 Selection of CAD Models 

First, specify CAD model files as the analysis shape. If you select "Mesh" -> "Select IGES Files" in the 

menu window, a window like the one in Fig. 2.5-1 appears. 

 

 

Fig. 2.5-1 IGES List Window 

 

When clicking the "add" button in Fig. 2.5-1, the file reading dialog (Fig. 2.5-2) is shown. Select 

"coil01.igs" in the "<AdvMagOnWin installation folder> \ sample_data \ shaft" folder and click "Open". 

 

 

Fig. 2.5-2 File Selection Dialog 
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If coil01.igs file is selected, it is added to the IGES list (Fig. 2.5-3). 

 

 

Fig. 2.5-3 IGES List after Selecting coil01.igs 

 

 Please add "coil02.igs", "mag.igs", "air.igs" in the similar process. The unit used in these files is [m]. If you 

add it all, it will look like Fig. 2.5-4. Click "OK" to load the IGES files. 

 

 

Fig. 2.5-4 IGES List after Selecting All Files 
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2.5.2 Settings for Node Density 

 Next, specify the node density. Select "Mesh" -> "Set Node Density" (Fig. 2.5-5). 

 

 

Fig. 2.5-5 Node Density Setting Dialog 

 

 There are three types of node density designation: point designation, line segment designation, and cylinder 

designation. It is also possible to read an ADVENTURE standard node density setting file. The unit used in a 

file is [m]. 

In this example, load the node density setting file from sample data. Please click "read file". When the file 

reading dialog (Fig. 2.5-6) appears, select "shaft.ptn" in the "<AdvMagOnWin installation folder> 

\sample_data\shaft" folder and click "Open". 

 

 

Fig. 2.5-6 Selection of Node Density Setting File 
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 As a result of loading the contents of the file, the basic node distance is changed to 0.01 [m], and a local 

node density setting of the cylinder type is added (Fig. 2.5-7). Click "OK" to complete the setting. 

 

 

Fig. 2.5-7 Settings for Node Density Dialog (After File Selection) 

 

2.5.3 Create Surface Patch 

 Next, make a surface patch from the CAD shape. When you select "Mesh" -> "Make Patch", the patch 

creation window (Fig. 2.5-8) appears. Click "OK" to make patch 

 

 

Fig. 2.5-8 Make Patch Dialog 

 

2.5.4 Mesh Generation 

 Next, we will generate a mesh. If you select "Mesh" -> "Make Mesh", the mesh generation window (Fig. 

2.5-9) appears. If you keep checking "correct surface patch" in the window, the surface patch is 

automatically corrected before generating mesh. Click "OK" to start mesh generation. 
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Fig. 2.5-9 Mesh Generation Dialog 
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 When the mesh generation is completed, the total number of elements and nodes is shown (Fig. 2.5-10). 

After confirming the number of elements and nodes, please click "OK". 

 

 

Fig. 2.5-10 Total Number of Elements and Nodes in Generated Mesh File 

 

 

Next, we set the property value and set the boundary conditions. 
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2.6 [Preprocess 2] Setting Analysis Conditions 

2.6.1 Setting Material Property Values 

Set material property values from "Analysis" -> "Set Material Property" -> "Electromagnetic Field 

Analysis" (Fig. 2.6-1). 

 

 

 

Fig. 2.6-1 Property Data Settings Dialog (Initial) 

 

In the initial screen, material property is automatically set for Property ID = 0, Magnetic Reluctivity = 

795774.7, Material Property Type = Other, Applied Volume = 0-3. Edit material properties as shown in 

Table 2.6-1. 

 

Table 2.6-1 Material Property Settings and Volume Correspondence 

Property ID Magnetic Reluctivity Material Property Type Applied Volumes 

0 795774.7 Coil 0-1 (coil01.igs, coil02.igs) 

1 757.1 Magnetic Material 2 (mag.igs) 

2 795774.7 Others 3 (air.igs) 
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First, change the Property ID 0 to the material property value of the coil. 

When you click the line of the Property ID 0, material property change dialog (Fig. 2.6-2) is shown. 

 

 

Fig. 2.6-2 Material Property Change Dialog (Initial) 

 

Follow the steps below to make changes. 

1) "Material Property Type" 

Change "Material Property Type" on the left side from "Others" to "Coil". 

The "coil" setting field becomes effective. 

2) "Coil" -> "Definition Type" 

Change from "RF" to "MD". 

3) "Coil" -> "Definition File" 

Select "coil.dat" in "<AdvMagOnWin installation folder>¥> \sample_data¥\shaft" folder as 

"Definition File". 

4) "Volume to be Applied" 

Change "Volume to be Applied" on the lower side to 0 - 1. 

  



ADVENTURE SYSTEM 

20 

 

 When setting changes are completed, please click "OK". The material property list is shown again (Fig. 

2.6-3) 

 

 

Fig. 2.6-3 Material Property List (After Coil Settings) 

 

Next, set the material property value of magnetic material. 

 When you click "Add Material Properties", the material property setting dialog will be shown. 

 Please select "Magnetic Material" as "Material Property Type". Next, input "757.1" to "Magnetic 

Reluctivity" and select "bh_curve" in "<AdvMagOnWin installation folder>¥>\ sample_data¥\shaft" as 

"Definition File" of "Magnetic Material". 

Finally, enter "2" as "Volume to be Applied". 

When all settings are completed, it becomes as shown in Fig. 2.6-4. Click "OK" to return to the material 

property list. 
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Fig. 2.6-4 Addition of Material Properties Dialog (After Setting of Magnetic Material) 

 

Finally, you will do the settings of the air. As in the case of the magnetic material, click on "Add 

Properties" and open the material property setting dialog. 

 Please select "Others" as "Material Property Type". Please enter "795774.7" as "Magnetic Reluctivity" and 

"3" as "Volume to be Applied". 

After all settings are made, it will be as shown in Fig. 2.6-5. Click "OK" to return to the property data 

settings dialog (Fig. 2.6-6). 
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Fig. 2.6-5 Addition of Material Properties Dialog (After Setting of Air Area) 

 

 

Fig. 2.6-6 Property Data Settings (After Setting is Complete) 

 

Please check whether there is any problem in setting and click "OK". 

 

2.6.2 Setting Boundary Condition 

 Next, set the boundary condition. First, if you select "Analysis" -> "Set Boundary Condition", the dialog in 

Fig. 2.6-7 appears. 
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Fig. 2.6-7 Set Boundary Condition Dialog 

 

 In this case, in order to reconstruct CAD surface information lost by mesh generation, surface triangle 

(patch) is grouped according to its normal direction, and a surface (patch group) is extracted. Pasting 

boundary conditions is done in patch group units. 

It is necessary to specify the two-sided included angle corresponding to the grouping resolution. The 

smaller the angle (the larger the value of (a) in Fig. 2.6-7), the more detailed the classification of the surface 

can be done. In the model of this time, there is no problem as it remains as standard, so please press "OK" as 

it is. The group division is performed automatically, and the window for setting the boundary condition is 

activated (Fig. 2.6-8). 

 

 

Fig. 2.6-8 Boundary Condition Setting Window (Initial State) 

 

At this time, the operation flow automatically changes from the list of the whole analysis steps so far to the 

operation steps of the boundary condition (Fig. 2.6-8 red arrow). In addition, guide messages corresponding 

to the operation steps are also shown in the message window, so please proceed with the operation while 

referring to here as well.  

(a) 
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On the boundary condition setting window, operate the view of the model as follows. 

 

 Rotation: 

Hold down the wheel button (middle button) and move the mouse to rotate the model. 

 Translation: 

Hold the left mouse button and move the mouse to move the model in parallel. 

 Zoom: 

Hold down the right button and move the mouse upward to zoom out or move it down to zoom in. 

 Node selection: 

Click the target node with the mouse to select the node. Yellow square is shown at the chosen node 

(although it is hard to see). 

 Surface selection: 

Right-click with the node selected, you can select the surface to which the node belongs. If you 

continue right clicking, another surface (which that node belongs to also) is selected. 

 

After selecting the node / surface for which you want to add the boundary condition, select "BC" -> "BC 

(Magnetic)" -> "Add Magnetic Vector Potential" in the boundary condition setting window. The magnetic 

vector potential boundary condition setting dialog appears (Fig. 2.6-9). 

 

 

Fig. 2.6-9 Boundary Condition Setting Dialog 

 

Please check "Normal" and click "OK". 

In this model, since the normal direction component of the magnetic vector potential is set to 0 on the entire 

surface, do the same setting for all the surfaces. 
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After adding the boundary conditions, you can check them by selecting "View" -> "Boundary Condition" -

> "Cnd Format" in the boundary condition setting window (Fig. 2.6-10). 

 

 

Fig. 2.6-10 Boundary Condition Confirmation Dialog 

 

After confirming that it is set as shown in Fig. 2.6-10, select "File" -> "Quit" in the boundary condition 

setting window. When the end confirmation dialog (Fig. 2.6-11) is shown, pressing "OK" automatically 

saves the set boundary conditions and the boundary condition setting window disappears. 

 

 

Fig. 2.6-11 Quit Confirmation Dialog 

 

2.6.3 Solver input file creation 

Next, select "Analysis" -> "Convert to Input File" and click "OK" in the input file creation dialog (Fig. 

2.6-12) to create a solver input file with mesh, boundary conditions, material properties. 

 

 

Fig. 2.6-12 Input File Creation Dialog 
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2.7 Analysis Execution 

2.7.1 Domain Decomposition 

ADVENTURE_Magnetic reads domain decomposition data based on HDDM as an input. If you select 

"Analysis" -> "Domain Decomposition", the domain decomposition dialog (Fig. 2.7-1) is shown. 

 

 

Fig. 2.7-1 Domain Decomposition Dialog 

 

Here, based on the number of elements of the mesh, you can specify the size of one subdomain (the 

smallest unit of the domain handled by one CPU) by one of the following two methods. 

 

 Number of elements contained in one subdomain (Click "Input # of elements/subdomain") 

 Number of subdomains in one part (Click "Input # of subdomains/part") 

 

Since numbers have already been entered so that it moves without problems in the initial settings, please 

click "Start" as it is this time. 
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2.7.2  

2.7.3 Solver Execution 

Calculation by solver is started. When you select "Analysis" -> "Run Solver", the solver execution dialog 

(Fig. 2.7-2) is shown. In the solver execution dialog, you can change various analysis condition options 

provided in the solver. There are four options: "I/O", "Non-linear Magnetostatic Analysis", "Subdomain 

Solver", and "HDDM Solver". 

 

 

Fig. 2.7-2 Solver Execution Dialog (I/O Option) 

 

I/O Option (Fig. 2.7-2) 

Maximum Memory Usage (MB) 

The upper limit of the memory used by each process is n [MByte]. If it exceeds this limit, 

execution stops at that point. 
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HDDM Solver Options (Fig. 2.7-3) 

 

 

Fig. 2.7-3 Solver Execution Dialog (HDDM Solver) 

 

Preconditioner 

Specify preconditioner to be used for HDDM 

 (No preconditioner) 

 Diagonal Scaling 

 

Tolerance for Convergence 

Specify the tolerance for convergence of HDDM. This is the relative error of the norm to the 

residual vector of the residual vector in the HDDM iteration, and it is judged that the HDDM 

iteration has converged when the relative error becomes smaller than this value. 

 

Tolerance for Divergence 

Specify the tolerance for divergence of HDDM. When the relative error becomes larger than this 

value, it is judged that the HDDM iteration has diverged and the program is terminated. 

 

Maximum Number 

Specify the upper limit of the number of HDDM iterations. If this value is exceeded, the program 

will terminate even before convergence is reached.  
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Non-linear Magnetostatic Field Analysis Options (Fig. 2.7-4) 

 

 

Fig. 2.7-4 Solver Execution Dialog (Non-linear Magnetostatic Analysis) 

 

Formulation Method 

Specify the type of formulation to be used. 

 A Method 

 A Method with the Lagrange multiplier (subdomain solver is forcibly changed to LU 

decomposition with pivoting) 

 

Non-linear Iterative Method 

Specifies the type of solution to use as a non-linear iterative method for the magnetic resistivity. 

 (Not Consider Non-linearity) 

 Newton Method 

 Picard Method 

 

Maximum Number of Iterations 

Specify the upper limit of the number of iterations of non-linear iteration. If this value is exceeded, 

the program will terminate even before convergence is reached. 

 

Tolerance for Convergence 

Specify the tolerance for convergence of non-linear iterations. When the error becomes smaller 

than this value, it is judged that the non-linear iteration has converged. 
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Tolerance for Divergence 

Specify the tolerance for divergence of non-linear iterations. When the error becomes larger than 

this value, it is judged that the non-linear iteration has diverged and the program is terminated. 

 

Characteristic Curve 

Select the characteristic curve to be used with the Newton method. Picard's successive 

approximation method is used for convergence judgment. 

 ν-B Curve 

 ν-B2 Curve  

 

Interpolation Method for Characteristic Curve 

Select interpolation method for characteristic curve with Newton method. Picard's successive 

approximation method is used for convergence judgment. 

 The First-order Interpolation  

 The Third-order Interpolation  

 

Weight for Picard Iterations μ 

Specify the weight of μ of Picard's successive approximation method. 

 

Subdomain Solver Options (Fig. 2.7-5) 

 

 

Fig. 2.7-5 Solver Execution Dialog (Subdomain Solver) 
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Preconditioner 

Specify preconditioner to be used for linear solver. The following character strings can be 

specified as s. 

 (No preconditioner) 

 Shifted Incomplete Cholesky Factorization (IC) 

Accelerative Parameter for IC 

Specify the accelerative parameter for shifted incomplete Cholesky factorization. 

 

Tolerance for Convergence 

Specify the tolerance for convergence of linear solver. When the error becomes smaller than this 

value, it is judged that the linear solver has converged. 

 

Tolerance for Divergence 

Specify the tolerance for divergence of linear solver. When the error becomes larger than this 

value, it is judged that the linear solver has diverged and the program is terminated. 

 

Execution of the solver 

There is no problem with the default settings, so click on "Start" without changing anything in the solver 

execution dialog. The solver calculation starts. 

The log of solver execution is output to <Documents>\advMagOnWin\ExecSolverForWin.log. Because the 

line feed code is in UNIX format (LF), please use a software that supports UNIX format line breaks such as 

WordPad, not Notepad. 

 

How to set the number of threads used by the solver 

Please refer to Section 1.4. 
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2.8 Result Visualizing 

To show the result, use external visualization software such as AVS or ParaView. Therefore, we will export 

the analysis results to a file for visualization. This time, we will explain the steps to visualize in ParaView. 

 

2.8.1 Start Visualizing 

If you select "Analysis" -> "Export Analysis Result", the export dialog of analysis result (Fig. 2.8-1) is 

shown. Select "Magnetic Flux Density" and "Electromagnetic Force" as the material quantities to output, 

"VTK format (such as ParaView)" as the output format, and specify the output folder (Fig. 2.8-1). 

 

 

Fig. 2.8-1 Analysis Result Export Dialog 

 

When you click "OK", two files "res.vtu" (magnetic flux density) and "res_NF.vtu" (electromagnetic force) 

are output to the selected folder.  

If the format is UCD (AVS), avs_B.inp and avs_NF.inp will be output, and if UCD (MicroAVS), 

mavs_B.inp and mavs_NF.inp will be output. 

If these files exist in the selected folder, the dialog for overwrite confirmation (Fig. 2.8-2) will be shown. 

Click “Cancel” to return to the original dialog, and specify the output folder again. 

 

 

Fig. 2.8-2 Confirm Overwrite Dialog 

 

2.8.2 Terminating AdvMagOnWin 

The operation of AdvMagOnWin is over at this point. 

By saving the analysis case in "File" -> "Save Analysis Case", you can re-analyze later. 

Exit AdvMagOnWin with "File" -> "Exit". 
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From this point on, it will be the explanation of ParaView operation. 

 

2.8.3 Launching ParaView and Reading Files 

After starting ParaView, open the file selection dialog (Fig. 2.8-3) from "File" -> "Open". First, to visualize 

the magnetic flux density, select "res.vtu" in the output folder and click "OK". 

 

 
Fig. 2.8-3 Selecting "res.vtu" 

 

You can see that "res.vtu" is selected on the left side of the ParaView main window (Fig. 2.8-4). 

 

 

Fig. 2.8-4 Main Window after Selecting "res.vtu" 

 

In this state, the file has not been read yet. Click "Apply" in the "Properties" column on the left side to 
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show the shape of the analysis model (Fig. 2.8-5). 

 

 

Fig. 2.8-5 Model Shape Display 

 

2.8.4 ParaView 3D screen operation method 

 

ParaView operates the 3D screen as follows. 

 

 Rotation: 

Hold down the left mouse button and move the mouse to rotate the model. 

 Translation movement:: 

Hold the mouse wheel button (middle button) and move the mouse to move the model in parallel. 

 Zoom: 

Turn the mouse wheel upward to zoom in, and turn down to zoom out. 

Alternatively, move the mouse upward while holding down the right button of the mouse to zoom 

out, move to the bottom to zoom in. 
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2.8.5 Mesh Display 

If you change "Representation" in the "Properties" box or "Surface" in the toolbar at the top of the screen to 

"Surface with Edges", the mesh will be shown (Fig. 2.8-6). 

 

 
Fig. 2.8-6 Mesh Display 

 

2.8.6 Display of Magnetic Flux Density 

If you change "Coloring" in the "Properties" box or "Solid Color" in the toolbar to "MagneticFluxDensity", 

the magnetic flux density is shown (Fig. 2.8-7).  

 

 

Fig. 2.8-7 Display of Magnetic Flux Density 

 

Slice 
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To see a specific part, cross section view is effective. To show cross section, select "Slice" (red frame part 

in Fig. 2.8-7) to enter section setting mode (Fig. 2.8-8). 

 

 

Fig. 2.8-8 After Selecting "Slice" 

 

In this example, we will extract the section near the bottom surface in the Y direction. Set the extraction 

direction selection button on the lower left to "Y Normal" and move the section (red frame) to the vicinity of 

the lowest surface in the Y direction (Fig. 2.8-9). 

 

 

Fig. 2.8-9 Setting Cross Section 
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When "Apply" is selected, the magnetic flux density of the extracted cross section is shown (Fig. 2.8-10). 

 

 

Fig. 2.8-10 After Cross Section Extraction 

 

Next, vector the magnetic flux on the section. Clicking on "Glyph" (red frame part in Fig. 2.8-10) results in 

the view shown in Fig. 2.8-11. If you click "Apply" here, a vector of magnetic flux will be shown with 

arrows (Fig. 2.8-12). 

 

 

Fig. 2.8-11 After Selecting "Glyph" 

 

Glyph 
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Fig. 2.8-12 Display of Magnetic Flux Vectors 

 

2.8.7 Display of Electromagnetic Force 

I will also visualize electromagnetic force. 

Open "res_NF.vtu" to show the electromagnetic force vector in the similar process as the magnetic flux 

density (but change it from "Solid Color" -> "Nodalforce"), as shown in Fig. 2.8-13. 

 

 

Fig. 2.8-13 Display of Vectors of Electromagnetic Force 
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3 Time-harmonic Eddy Current Analysis 
This chapter explains the procedure of time-harmonic eddy current analysis using the sample data supplied 

with AdvMagOnWin. 

 

3.1 About the model used 

The unit system used in this chapter is SI. It is not necessary to declare a unit system when using 

AdvMagOnWin. The model used in this chapter is a cake model, which is an accuracy verification model for 

eddy current analysis using an infinite-length solenoid coil. Fig. 3.1-1 shows this model. The analysis area is 

the area cut out 20˚ around the z-axis from Fig. 3.1-1. The radius of the conductor part is 0.1 [m]. 

The magnetic resistivity ν is 1 / (4π × 10 −7) [m / H] in the whole analysis area, the conductivity σ of the 

conductor is 7.7 × 106 [S / m], and the angular frequency ω is 2π × 60 [rad / s] = 376.9911. The magnitudes 

of the real and imaginary parts of the forced current density J flowing in the coil are 50 and 0 [A / m2], 

respectively. A list of material property values is shown in Table 3.1-1. 

Considering the symmetry of the problem, a fan-shaped area with a central angle of 20˚ and a height of 

0.1 m is taken as the model to be analyzed (see Fig. 3.1-2). As boundary conditions, A × n = 0 and an 

electric scalar potential φ = 0 [V] are imposed on the faces of θ = 0˚ (green) and θ = 20˚ (red) as shown in 

Fig. 3.1-3. A is a magnetic vector potential [Wb / m], n is a unit normal vector of the boundary surface. 

 

 

Fig. 3.1-1 Infinite length solenoid coil 

 

Table 3.1-1 Material property list 

Property 

ID 

Part Magnetic 

resistivity 

 (m/H) 

Conductivity (S/m) Volume applied 

0 Conductor 795774.7 7.7e6 0 (conductor.igs) 

1 Inside air 795774.7 Not applicable 1 (air01.igs) 

2 Coil 795774.7 Not applicable 2 (coil.igs) 

3 Outer air 795774.7 Not applicable 3(air02.igs) 
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Fig. 3.1-2 Cake Model 

 

 

Fig. 3.1-3 Boundary Conditions 

 

Table 3.1-2 List of Material Properties 

 Material  Magnetic Reluctivity B-H Characteristic 

Coil 795774.7 - 

Magnetic Material 757.1 - 

Air 795774.7 Apply Fig. 2.1-2‘s 

characteristic curve 
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3.2 Starting the Software 

 Please refer to section 2.3.  

 

3.3 Creating Analysis Case 

This is very similar to the case in Section 2.4, but in "Analysis Type (Subtype)-Electromagnetic Field 

Analysis", select "Time-harmonic Eddy Current" and click "Next" (Refer to Fig. 3.3-1).  

 

 

Fig. 3.3-1 Analysis Type (Subtype) 

 

Next, the window in Fig. 3.3-2 appears. Select "IGES" as the geometry model. You can only select "Linear 

Tetrahedron (Edge Element)" in the analysis model, so just click "Next". 

 

 

Fig. 3.3-2 Element Type 

 

 These operations create an analysis case and display a list of required operations in the procedure guide 

window. Follow the procedure shown in the procedure guide window and the message window for the 
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subsequent operations.  

Next, we will generate a mesh. 
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3.4 [Preprocess 1] Mesh Generation 

3.4.1 Selection of CAD Models 

The method of specifying a CAD model file as the analysis shape is as described in section 2.5.1. The files 

to be selected specifically are in the <AdvMagOnWin installation folder>\sample_data\cake\igs folder. 

As shown in Fig. 3.4-1, select conductor.igs, air01.igs, coil.igs, and air02.igs in this order, and click OK to 

import the IGES files into the analysis case. Table 3.4-1 shows the contents of each IGES file and the area it 

occupies. 

 

 

Fig. 3.4-1 IGES List Window 

 

Table 3.4-1 Information on each IGES files 

Volume 

ID/Property ID 

IGES file name Area name  Range of area  

0 conductor.igs Conductor area 0 ≤ r ≤ 0.1 

1 air01.igs Inside air area  0.1 ≤ r ≤ 0.15 

2 coil.igs Coil area 0.15 ≤ r ≤ 0.17 

3 air02.igs Outer air area 0.17 ≤ r ≤ 0.25 
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3.4.2 Settings for Node Density 

 Next, specify the node density. Select "Mesh" -> "Set Node Density" (Fig. 3.4-2). 

 

 

Fig. 3.4-2 Node Density Setting Dialog 

 

 In this analysis example, the node density setting file prepared as example data is read. Click on "read file". 

When the file open dialog (Fig. 3.4-3) is displayed, select "cake.ptn" in the "<AdvMagOnWin installation 

folder>\ sample_data\cake\igs" folder and click "Open". 

 

 

Fig. 3.4-3 Node Density Setting File Selection 

 

As a result of reading the contents of the file, the basic node spacing is changed to 0.02 m, and two local 

node density settings of Cylinder type are added (Fig. 3.4-4). Click OK to complete the configuration. 
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Fig. 3.4-4 Node Density Setting Dialog after File Selection 

 

3.4.3 Create Surface Patch 

 Next, create surface patches from CAD shapes. If you select "Mesh" -> "Make Patch", the make patch 

dialog (Fig. 3.4-5) will be displayed. Click "OK" to create a patch. 

 

 

Fig. 3.4-5 Make Patch Dialog 

 

3.4.4 Mesh Generation 

 Next, we will generate a mesh. If you select "Mesh" -> "Make Mesh", the mesh generation dialog (Fig. 

3.4-6) appears. If you leave the "correct surface patch" checkbox in the dialog as it is, the surface patch is 

automatically corrected before mesh creation. Click "OK" to begin meshing. 

 

 

Fig. 3.4-6 Mesh Generation Dialog 
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 When mesh generation is complete, the total number of elements and the total number of nodes will be 

displayed (Fig. 3.4-7). After confirming the number of elements and that of nodes, please click "OK". 

 

 

Fig. 3.4-7 Total Number of Elements and Nodes in Mesh File 

 

 

Then, set the material property values and the boundary conditions. 
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3.5 [Preprocess 2] Setting Analysis Conditions 

3.5.1 Setting Material Property Values 

Material property values are set from "Analysis" -> "Set Material Property" -> "Electromagnetic Field 

Analysis" (Fig. 3.5-1). 

 

 

Fig. 3.5-1 Material Property List (Initial) 

 

In the initial screen, one material property with property ID = 0, magnetic resistivity = 795774.7, material 

property type = other, volumes applied = 0-3 is automatically set. Modify the existing physical property ID 

and add a new material property ID so that the settings shown in Table 3.1-1 are made. 

 

First, change the material property value of Property ID = 0 to that of the conductor. 

When the Property ID 0 is clicked, the property change dialog (Fig. 3.5-2) is displayed. 
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Fig. 3.5-2 Material Property Settings Dialog (Before Editing) 

 

Make the change in the following procedure. 

1) "Material Property Type" 

Change "Material Property Type" on the left side from "Others" to "Conductor".  

The "Conductor" setting field is enabled. 

2) "Conductivity" value 

Change the "Conductivity" value from "0.0" to "7.6e6". 

3) "Volume to be Applied" 

Change "Volume to be Applied" at the bottom from to "0-3" to "0" (Fig. 3.5-3). 

 

After setting change is complete, click on "OK". The material property list dialog is shown again (Fig. 

3.5-4). 

 



ADVENTURE SYSTEM 

49 

 

 

Fig. 3.5-3 Property Settings Dialog (After Completion of Conductor Area Editing) 

 

 

Fig. 3.5-4 Material Property Settings Dialog (After Conductor Setting) 
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Next, set the material property value of the inside air area. 

Click "Add Material Properties" to display the "Addition of Material properties" dialog.  

For "Material Property Type", leave "Others" specified by default as it is. Enter "795774.7" for "Magnetic 

Reductivity" and enter "1" for "Volume to be Applied".  

Fig. 3.5-5 is in the state where editing is finished. Click "OK" to return to the property data setting dialog. 

 

 

Fig. 3.5-5 Material Property Setting Dialog (When Air Area Editing is Complete) 

 

Next, set the coil area. Click "Add Material Properties" and edit the newly displayed dialog as follows. 

1) "Material Property Type" 

When changing from "Others" to "Coil", the "Coil" setting field becomes enabled. 

2) "Magnetic Reductivity" 

Change "0.0" to "795774.7". 

3) "Coil" -> "Definition type" 

Change from "RF" to "MD". 

4) "Coil" -> "Definition File" 

Select "coil.dat" in the "<AdvMagOnWin installation folder>\ sample_data\cake\done" folder 

as the "Definition File". 

5) "Volume to be Applied" 

Set the "Volume to be Applied" to "2" at the bottom of the dialog. 

 

When all settings are complete, it becomes as shown in Fig. 3.5-6. Click "OK" to return to the Property  

Data Settings Dialog (Fig. 3.5-7). 
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Fig. 3.5-6 Material Property Settings Dialog (After Coil Area Editing is Complete) 

 

 

Fig. 3.5-7 Property Data Setting Dialog (After Coil Area Setting is Complete) 
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Next is the setting of the outer air area. It is almost identical to the inner air area setting. The only 

difference is that "3" is specified as "Volume to be Applied" (Fig. 3.5-8). 

 

Fig. 3.5-8 Material Property Settings Dialog (when Editing of the Outer Air Area is Complete) 

 

Finally, set the angular frequency in Fig. 3.5-9. Use the default value of 376.9911 according to the problem 

settings. Then click "OK". 
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Fig. 3.5-9 Property Data Setting Dialog (After Settings of All Property IDs are complete) 

 

3.5.2 Setting Boundary Condition 

 Next, set the boundary condition. First, select "Analysis" -> "Set Boundary Condition", and the dialog 

shown in Fig. 3.5-10 will be displayed. 

 

 

Fig. 3.5-10 Boundary Condition Setting Dialog 

 

 

Here, surface triangles (patches) are grouped by their normal directions to extract faces (patch groups) in 

order to reconstruct CAD topology information lost due to mesh generation. Boundary conditions are added 

on a patch group basis. 

It is necessary to specify a two-sided included angle that corresponds to the resolution of the grouping. The 

smaller the angle (the larger the value in (a) in Fig. 3.5-10), the finer the surface can be classified. For the 

current model, there is no problem with the default, so just click "OK". Group division is performed 

automatically, and the window for setting boundary conditions (ADVENTUR_BcGUI 2.0) is launched (Fig. 

(a) 
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3.5-11).  

 

Fig. 3.5-11 Boundary Condition Setting Window (Immediately After Startup) 

 

At this time, the display of the procedure guide window automatically changes from the whole analysis 

procedure to the boundary condition setting procedure (Fig. 3.5-11 red arrow). Suggestions corresponding to 

the procedure will also be displayed in the message window, so please proceed according to the suggestions. 

Refer to section 2.6.2 for how to operate the 3D model on the boundary condition setting screen. 

There are two faces to set the boundary condition as shown in Fig. 3.1-3. For example, after selecting the 

face with θ = 0˚, select "BC" -> "BC (Magnetic)" -> "Add Magnetic Vector Potential" in the menu of the 

boundary condition setting window (Fig. 3.5-12). Notice also that the selected Surface Group ID is displayed 

as 1 in the lower status bar in Fig. 3.5-12. The Magnetic vector potential boundary condition setting dialog is 

displayed (Fig. 3.5-13). 
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Fig. 3.5-12 Selection of the Menu Item for Boundary Condition Setting  

After Selecting the Surface with θ = 0˚ 

 

 

Fig. 3.5-13 Boundary Condition (Magnetic Vector Potential) Setting Dialog 

 

Check "Normal" as indicated by a red circle in the figure, keep the value zero and click "OK". Similarly, set 

the same conditions for the surface of θ = 20˚. As electric scalar potential φ = 0 is a natural boundary 

condition, setting is not necessary. 
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After setting the boundary conditions, select "View" -> "Boundary Condition" -> "Cnd format" in the 

boundary condition setting window to check the set boundary conditions (Fig. 3.5-14). 

 

 

Fig. 3.5-14 Boundary Condition Confirmation Dialog 

 

After confirming that the settings are as shown in Fig. 3.5-14, click the OK button and select the "File"-> 

"Quit" menu item. When the quit confirmation dialog (Fig. 3.5-15) is displayed, pressing "OK" will 

automatically save the set boundary conditions and the boundary condition setting window will disappear. 

 

 

Fig. 3.5-15 Quit Confirmation Dialog 

 

3.5.3 Solver input file creation 

Then select "Analysis"-> "Convert to input file" and click "OK" in the input file creation dialog (Fig. 

3.5-16). A solver input file is created that merges meshes, boundary conditions, and material property 

values1. 

 

                                                        
1 To be precise, only the file that describes the relationship between volume ID and material property ID is 

included in the solver input file. There is no need to worry about that as long as you are using the Windows 

version. 
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Fig. 3.5-16 Input File Creating Dialog 

 

3.6 Analysis Execution 

3.6.1 Domain Decomposition 

ADVENTURE_Magnetic reads domain decomposed data based on the HDDM as input. Select "Analysis"-

> "Domain Decomposition", to display the domain decomposition dialog (Fig. 3.6-1). 

 

 

Fig. 3.6-1 Domain Decomposition Dialog 

 

Here, based on the number of elements of the mesh, the size of a subdomain (the smallest unit of the 

domain handled by one CPU) can be specified by one of the following two methods. 

 

 Number of elements contained in a subdomain (Click "Input # of elements/subdomain") 

 Number of subdomains in a part (Click "Input # of subdomains/part") 
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The recommended values have already been entered automatically so that domain decomposition can be 

performed without problems, so just click on "Start". 
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3.6.2 Solver Execution 

Next is the start of the calculation by the solver. Select "Analysis"-> "Run Solver" and the solver run dialog 

(Fig. 3.6-2) will be displayed. 

 

 

Fig. 3.6-2 Solver Execution Dialog (I/O option) 

 

In the solver execution dialog, you can change various analysis condition options provided by the solver. 

The options are divided into four parts: “I/O”, “HDDM Solver”, “Non-linear Magnetostatic Analysis”, 

“Subdomain Solver”, and “Time-harmonic Eddy Current Analysis”. 

 

I/O Option (Fig. 3.6-2) 

Please refer to Section 2.7.2. 

 

HDDM Solver Options (Fig. 2.7-3) 

Please refer to Section 2.7.2. 

 

Time-harmonic Eddy Current Analysis Option (Fig. 3.6 3) 

Refer to Fig. 3.6-3. 
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Fig. 3.6-3 Solver Execution Dialog (Time-harmonic Eddy Current Analysis Option) 
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Formulation Method 

Specify the type of formulation to be used. 

 A Method 

 A-𝜙Method  

 

Subdomain Solver Options (Fig. 2.7-5) 

Please refer to Section 2.7.2. 

 

Execution of Solver 

There is no problem with the default settings, so click on "Start" without changing anything in the solver 

execution dialog. The solver calculation starts. 

The log of solver execution is output to <Documents>\advMagOnWin\ExecSolverForWin.log. Because the 

line feed code is in UNIX format (LF), please use a software that supports UNIX format line breaks such as 

WordPad, not Notepad2. 

  

                                                        
2 Notepad on Windows 10 October 2018 Update (1809) now supports LF. 
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3.7 Result Visualization 

The way to display the results is the same as described in section 2.8. Here we will explain only the 

differences from Section 2.8. Also, the description of the visualization method by MicroAVS and 

AVS/Express is omitted. 

 

3.7.1 Start of Visualization 

If you select "Analysis" -> "Export Analysis Result", the Export Analysis Result Dialog (Fig. 3.7-1) will be 

displayed. Of the physical quantities to be output, "Electromagnetic Force" cannot be selected because it is 

not used in this analysis type. Select "VTK Format (such as ParaView)" as the output format, and specify the 

output folder (Fig. 3.7-1). 

 

 

Fig. 3.7-1 Export Analysis Result Dialog 

 

When "OK" is clicked, nine files, i.e., "res.vtu3" (magnetic flux density and eddy current density, VTK), 

"avs_Bi.inp" (magnetic flux density (imaginary part), AVS/Express), "avs_Br.inp" (magnetic flux density 

(real part), AVS/Express), "mavs_Bi.inp" (magnetic flux density (imaginary part), MicroAVS), 

"mavs_Br.inp" (magnetic flux density (real part), MicroAVS), "avs_Jei.inp" (eddy current density 

(imaginary part), AVS/Express), "avs_Jer.inp" (eddy current density (real part), AVS/Express), 

"mavs_Jei.inp" (eddy current density (imaginary part), MicroAVS), and "mavs_Jer.inp" (eddy current 

density (real part), MicroAVS) will be output. 

 

3.7.2 Terminating AdvMagOnWin 

Please refer to section 2.8.2. 

 

3.7.3 Launching ParaView and Reading Files 

In this section, we used version 5.6.0 of ParaView for Windows (64 bit). After launching ParaView, open 

the file selection dialog (Fig. 3.7-2) from "File"-> "Open". To visualize the magnetic flux density, select 

"res.vtu" in the output folder specified in section 3.7.1 and click "OK". 

 

                                                        
3 The vtu extension corresponds to unstructured grid data in VTK format. 
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Fig. 3.7-2 Selecting "res.vtu" 

 

You can see that "res.vtu" is selected in the left part of ParaView's main window (Fig. 3.7-3). 

 

 

Fig. 3.7-3 Main Window after Selecting "res.vtu" 
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The file has not been read yet in this state. Click "Apply" in the "Properties" tab on the left to display the 

shape of the analysis model (Fig. 3.7-4). 

 

 

Fig. 3.7-4 Showing the Model Shape 

 

3.7.4 Method of 3D Screen Operation of ParaView 

 

See Section 2.8.4. 

 

  



ADVENTURE SYSTEM 

65 

 

3.7.5 Displaying Mesh 

If you change "Representation" in the "Properties" tab or "Surface" (Fig. 3.7-6) in the toolbar at the top of 

the screen to "Surface with Edges", the mesh will be displayed (Fig. 3.7 6). 

 

 

Fig. 3.7-5 Switching to Mesh Display 

 

 

Fig. 3.7-6 Mesh Displayed 

 

3.7.6 Displaying Magnetic Flux Density 

If you change "Coloring" in the "Properties" tab or "Solid Color" in the toolbar to "MagneticFlux Density-

Imag" (Fig. 3.7-7), the imaginary part of the magnetic flux density is displayed (Fig. 3.7-8). 
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Fig. 3.7-7 Switching to Display of Each Variable 

 

 

Fig. 3.7-8 Display of Magnetic Flux Density Imaginary Part 

 

The color map is different from the commonly used one, so let's change it. With the data whose color you 

want to adjust is selected in the tree, click "Edit Color Map"  (red circle in Fig. 3.7-10). 
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Fig. 3.7-9 Location of "Edit Color Map" 

 

To make detailed settings for "Edit Color Map", click the gear icon  (red circle in Fig. 3.7-10). 

 

 

Fig. 3.7-10 Gear Icon 

 

Click the icon  to change the color map (Fig. 3.7-11). 
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Fig. 3.7-11 The Icon for Changing Color map 

 

Selecting "jet" (red ellipse 1) in the "Choose Preset" dialog (Fig. 3.7-12) will display the most commonly 

used color map. After clicking on "Apply" (red ellipse 2) in the lower right group of buttons, close the dialog 

with "Close" (red ellipse 3). 

 

 

Fig. 3.7-12 Preset Color Map Selection Dialog  

 

Clicking on the button to the right of "Color Map Editor" closes the "Color Map Editor" and the main 

screen looks like Fig. 3.7-13. 
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Fig. 3.7-13 Imaginary Part of Magnetic Flux Density after Color Map Change 

 

Next, draw a vector diagram, but before that, change the whole model to wireframe display. Select 

“Wireframe” from the pull-down in Fig. 3.7-14. 

 

 
Fig. 3.7-14 Selecting Wireframe 

 

When the wire frame display is displayed, click “Glyph” indicated by a red circle in Fig. 3.7-15. 
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Fig. 3.7-15 Selecting Glyph while Displaying in Wire Frame 

 

Select "MagneticFluxDensity-Imag" again in "Orientation Array" or "Scale Array". For this result, for 

example, "Scale Factor" was set to 30,000. Press “Apply” and the vector will be displayed (Fig. 3.7-16). 

 

 

Fig. 3.7-16 Vector Diagram (Imaginary Part of Magnetic Flux Density) 

 

Similarly, the real part of the magnetic flux density (Fig. 3.7-17), the imaginary part of the eddy current 

density (Fig. 3.7-18), and the real part of the eddy current density (Fig. 3.7-19) are shown. For these, "Blue 

to Red Rainbow" was adopted as a color map. 
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Fig. 3.7-17 Vector Diagram (Real Part of Magnetic Flux Density) 

 

 

Fig. 3.7-18 Vector Diagram (Imaginary Part of Eddy Current Density) 
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Fig. 3.7-19 Vector Diagram (Real Part of Eddy Current Density) 

 

4 Useful Functions 

4.1 Mesh Extraction of Selected Volume 

From the mesh consisting of multiple volumes, create a partial mesh consisting of nodes and elements 

contained in some selected volumes. 

After generating the mesh, select "Mesh" -> "Extract Selected Volume", the mesh extraction dialog (Fig. 

4.1-1) of the selected volume will be shown. 

 

 

Fig. 4.1-1 Volume Selection Window 
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Select the volume you want to extract and click the button to the right of the input field of "Output File", 

the save dialog (Fig. 4.1-2) will be shown. Please specify the save destination directory, enter the prefix of 

output files and click "Save". However, saving of the file is not completed yet. 

 

 
Fig. 4.1-2 File Saving Destination Selection Dialog 
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Since you will return to the volume selection screen again, please click "OK" when you confirm that the file 

name is entered in the "Output File" column. This completes saving, and the four files "<file name>.msh", 

"<file name>.src_node", "<file name>.src_elem", and "<file name>.src_vol" are output. When these files 

exist in the selected folder, the dialog for overwrite confirmation (Fig. 4.1-3) will be shown. If you want to 

overwrite, click "OK". Otherwise, click "Cancel" and return to export dialog. 

 

 

Fig. 4.1-3 Confirm Overwrite Dialog 

 

As an extraction example, Fig. 4.1-4 shows the visualization result of the mesh extracted only volume 0 

from the mesh created in Chapter 2. 

 

 

Fig. 4.1-4 Result of Visualization of Extracted Mesh 
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4.2 Creation of B-H curve definition file 

You can compose the relationship (B-H curve) between the magnitude of magnetic field strength H [A / m] 

and the magnitude of magnetic flux density B [T], which is the material property of the magnetic material, 

while viewing the plot result and save it as a file. The B-H curve is defined by specifying two or more sizes 

of B (| B |) and H (| H |) and defining the segmented curves connecting these points. 

 

4.2.1 Startup 

When you select "Analysis" -> "Set Material Property" -> "Create B-H Curve Definition File" with 

AdvMagOnWin activated, the B-H curve definition file creation window (Fig. 4.2-1 is shown). 

 

 

Fig. 4.2-1 B-H Curve Definition File Creating Window 

 

The plot area of the B-H curve is shown on the left side of the screen. On the right side there are a list of 

defined values of the B-H curve, four buttons for the definition value manipulation function, and a button for 

closing the creation window. 

 

4.2.2 Adding definition values 

When you click "Add Value", the Add Item dialog (Fig. 4.2-2) is shown, so enter the value of the definition 

point of the B-H curve (Fig. 4.2-3). Please input the size of H (| H |) and the size of B (| B |) respectively. 

 

 
Fig. 4.2-2 Add Item (Initial) 

 
Fig. 4.2-3 Add Item (After Input) 

 

Click "OK" to return to the original screen, the specified point is shown at the center of the graph on the left 
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side, and the coordinate value of the point specified on the right side is shown (Fig. 4.2-4). The scale of the 

graph changes depending on the size of the specified value. 

 

 

Fig. 4.2-4 After Adding Definition Point 

 

If you add another point, the points added to the graph are also shown, and a line is drawn between the 

points that originally existed (Fig. 4.2-5). The table on the right side of the screen is always sorted 

automatically with the value of | H |. 

 

 

Fig. 4.2-5 Show 2 Added Points 
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4.2.3 Delete definition value 

To delete an unnecessary definition value, select the row of the definition value you want to delete and click 

"Delete Selected Value" to delete it (Fig. 4.2-6) 

 

 

Fig. 4.2-6 After Deleting The Definition Point (1.0, 2.0) 

 

4.2.4 Reading the definition file 

To read the B-H curve definition file of the format used for ADVENTURE_Magnetic, click "Read File" 

and select the file in the file selection dialog. 

Fig. 4.2-7 shows the state immediately after reading the sample data bh_curve file. 

 

 

Fig. 4.2-7 After Reading Sample Data "bh_curve" 
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4.2.5 Saving the B-H curve definition file 

By clicking "Write File", you can save the created B-H curve definition in a file (Fig. 4.2-8) 

 

 

Fig. 4.2-8 Save Dialog 

 

When the file with same name exists in the selected folder, the dialog for overwrite confirmation (Fig. 

4.2-9) will be shown. If you want to overwrite, click "OK". Otherwise, click "Cancel" and return to original 

screen. 

 

 

Fig. 4.2-9 Confirm Overwrite Dialog 

 

4.2.6 Creation complete 

Click "Close" to finish creating the B-H curve definition. 

Before closing, please check whether it saved in the file. 


