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1. Outline1. Outline1. Outline1. Outline 

The purpose of this module is to support the user in making decisions by permitting 

multi-dimensional visualization of optimized calculation results. The module has the following 

features: 

 

(1) This module reads databases of multipurpose optimization analysis results, groups many 

design variables and analysis results into factors of three or fewer dimensions and provides 

multi-dimensional visualization capability while showing the relations among factors. This 

module may also be utilized to visualize results of other simulation data with user’s creativity. 

(2) The displayed cases and factors can be reduced and switched using interactive operations.  

(3) Although simplifying the display by grouping too many variables into three or fewer variables 

and dividing them into groups makes the data of a case to be shown as multiple points, these 

points can be connected with a line to indicate that they are the same data of a case. 

(4) This module enables three dimensional rotation/ zooming/ pan.  

(5) This module enables users to switch display items, and to identify whether results satisfy 

constraints. This visually supports users in making decisions about selecting optimal cases. 

(6) Preferences for visualization, such as colors and types of lines and points, and fonts can be 

customized. 
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2. Operation Environment2. Operation Environment2. Operation Environment2. Operation Environment    

This module operates in the following environment.  

(1) OS 

Windows 2000 Professional, Windows XP Professional 

(2) Compiler 

A compiler is not required since the module is provided precompiled.  
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3. Installation and Setup3. Installation and Setup3. Installation and Setup3. Installation and Setup 

After logging in to the Windows as an authorized user, run the installer AdvDmV1e.exe. The 

window shown in Fig. 3-1 will appear.  

 

Fig. 3-1 Initial stage of installation 

 

It will automatically change as shown in Fig. 3-2. 

 

Fig. 3-2 Window for language selection at installation 

 

Select a language and Click “OK” on the screen shown in Fig. 3-2. The window shown in Fig. 3-3 

will appear. 

 



ADVENTURE SYSTEM 

7 

 

Fig. 3-3 Windows at installation start-up. 

 

Click “Next” and the window in Fig. 3-4 will appear. You will be asked whether you accept the 

terms of the License Agreement. To accept, select the “I accept the terms of the License Agreement” 

radio button and click “Next”. 

 

Fig. 3-4 License agreement 

The screen shown in Fig. 3-5 will appear requesting you to select a folder for installation. 
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Fig. 3-5 Choosing an installation folder 

 

The “C:\Program Files\ ADVENTURE_DecisionMakerVer1_0” folder is set as a default. If you 

wish to specify a different folder, click “Choose…”. Fig. 3-6 will appear and allow you to select a 

folder for installation. 

 

Fig. 3-6 Choosing an installation folder 

 

You may return to the default installation folder even after selecting an alternative by clicking 

“Restore Default Folder”. After selecting a folder, click “Next”.  

At the window shown in Fig. 3-7, select a location for the shortcut for this module. Bear in mind 

that you can choose only one folder. If you need a shortcut on the Desktop in addition to the Start 

menu, select one here and create the other manually. After selecting a location, click “Next”. 
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Fig. 3-7 Choosing a shortcut folder 

 

The window shown in Fig. 3-8 will appear. 

 

Fig. 3-8 Pre-installation summary 

 

In this window, the installation settings you have selected and the available disk space will be 

displayed. After confirming that there is no problem, click “Install”. 

The window shown in Fig. 3-9 will appear and installation will begin. 
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Fig. 3-9 Installing ADVENTURE DecisionMaker Ver.1.0 

 

After a period of installation activity, the window shown in Fig. 3-10 will appear automatically. 

Click “Done” to complete installation. 

 

Fig. 3-10 Completion of installation 
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4. W4. W4. W4. Whhhhat Is A Multiat Is A Multiat Is A Multiat Is A Multi----dimensdimensdimensdimensional Visualizationional Visualizationional Visualizationional Visualization    

 A “multi-dimensional visualization” may not be a familiar phrase. This application was designed 

mainly to display calculation results for multipurpose parametric optimization. The calculation 

results for multipurpose parametric optimization consist of multiple design variables and multiple 

objective functions. As a result of optimization calculation, objective functions are plotted for each 

combination of very many design variables.  

When there is only one objective function, users may select only a case in which the value for the 

objective function is largest or smallest. In this case, users’ decision making is not complicated. 

However, when more than one objective functions exist, it is not easy to select an optimal case as 

they all have cons and pros. 

This visualization system was proposed and developed to support decision making in such cases. 

This application is able to display not only values in all cases of design variables and objective 

functions, but also display whether or not a datum is in or out of range using constraints (such as the 

minimum and maximum values). specified by the user. 

Let’s explain it through Fig. 4-1. First, an item of data is displayed as a point (the green star in the 

figure) in a space. When the data has the value: variable 1=a, variable 2=b, variable 3=c, it is plotted 

at the position given by coordinates (a, b, c) in a three-dimensional space where the x, y and z axes 

corresponds to variable 1, variable 2 and variable 3, respectively. Variable 1 to variable 3 cannot be 

just any combination but belong to either design variables or objective functions (we call this a 

factor group). There are cases in which there are more than three design variables. In such cases, you 

may select only three out of the whole number of design variables.  

Variable 1

Variable 2

Variable 3

A data point is 

indicated where

Variable 1 = a

Variable 2 = b

Variable 3 = c

Variables 1 to 3 

belong to one 

factor group.

 
Fig.4-1 A data point plotted in the space frame of Variables 1 to 3 

 

It is also possible to create another three-dimensional space and plot the same case next to the 

factor group 1 as shown in Fig. 4-2. In this case, the two points in the two spaces are connected by a 

straight line to indicate that they are the same case (this line can be hidden if the user wishes so). In 

the figure, there are labels: Factor group 1 and Factor group 2. User named them for the subsets of 

design variables in each space. 
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Variable 1

Variable 2

Variable 3

Variable 5

Variable 6

Variable 4

Factor group 1

Factor group 2

• One point is 

indicated by 

Variables 1 to 3, 

the other by 

Variables 4 to 6. 

They are 

connected by a 

line, which 

means they are 

in the same data 

set.

 

Fig. 4-2 An example of data plotting using two display spaces when one space is insufficient. 

 

In cases in which the number of design variables is less than three, the case is indicated using one 

or two axes in three-dimensional space, as show in Fig. 4-3. 

Variable 1

Variable 3

Variable 2

Factor group 1

Factor group 2

• One point is 

indicated by 

Variable 1, the 

other by 

Variable 2 to 3.  

They are 

connected by a 

line, which 

means they are 

in the same data 

set.

 

Fig. 4-3 An example of one or two axes presented in display spaces 

 

Until now we have described how data is indicated in each space. From here we will explain how 

to indicate design variables, objective functions and constraints. See the image at Fig. 4-4. One space 

is for design variables, the next is for objective functions, the last one for constraints in the figure. 

However, as explained at Fig. 4-2, there are cases in which each could have more than one spaces. 

Constraints themselves are not data but are actually design variables or objective functions. They 

help users understand data tendencies or correlations, if they are utilized to display data in different 

cross-sections, such as showing it by combining any of design variables and any of objective 

functions. 
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Space of      

design variables

Space of   

objective functions

Space of 

constraints 

 

Fig. 4-4 Image when all spaces of design variables, objective functions and constraints are created 

 

Fig. 4-5 shows the relationship between the spaces for design variables, objective functions and 

constraints, and the factor groups which each of the spaces possesses. The name “factor group” 

simply refer to grouped variables in each space.  

Space of     

design variables

Space of   
objective functions

Space of 

constraints

Factor group1

Factor group2

Factor group3

Factor group1

Factor group2

Factor group3

Factor group1

Factor group2

Factor group3

… … …
 

Fig. 4-5 Relationship between spaces for design variables, objective functions and constraints, and 

the factor groups of each space 

 

To finish, an actual example of data display is shown in Fig. 4-6. 
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Fig.4-6 An example of actual data display 

 

This concludes the explanation for multi-dimensional visualization.    
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5. Data Typ5. Data Typ5. Data Typ5. Data Typeseseses    

Two kinds of data files are used. One is an item definition file that describes display items. The 

other is an analysis data file that contains design variables and objective functions. Visualization is 

possible only after both files are read. The format specifications for the Item definition file are 

described in Appendix 1. Format of Item Definition File, and those for the analysis data file are 

given in Appendix 2. Format of Analysis Data File.  

 

There is no particular restriction on file extensions. Practices are “def” for item definition files and 

“dat” or “csv” for analysis data files. 
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6. Operating Instructions for Visualization6. Operating Instructions for Visualization6. Operating Instructions for Visualization6. Operating Instructions for Visualization    

6.1 Startup Procedure6.1 Startup Procedure6.1 Startup Procedure6.1 Startup Procedure    

Select or double-click the shortcut created at installation to start the application. If, for example, 

the shortcut has been created on the desktop, double-click the icon:  

(ADVENTURE_DecisionMakerV1_0). The actual executable is 

ADVENTURE_DecisionMakerV1_0.exe in the installation folder. Fig. 6.1-1 will appear just after 

startup. 

 

Fig. 6.1-1 Screen right after startup 

 

6.2 Reading Data Files6.2 Reading Data Files6.2 Reading Data Files6.2 Reading Data Files    

Select “File” > “Open”, and the dialog shown in Fig. 6.2-1 will appear. 

 
Fig. 6.2-1 Dialog for file selection 

 

First, click “Select” to the right of “Item definition file” and the screen shown in Fig. 6.2-2 

appears. 
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Fig. 6.2-2 Dialog for selection of item definition file 

 

Let’s read some sample data. Select “samples” under the installation folder and Fig. 6.2-3 will 

appear. Select “opt_en.def” and click “Open”. 

 

Fig. 6.2-3 Selection of a sample item definition file opt_en.def 

 

Fig. 6.2-1 changes to Fig. 6.2-4. 

 

Fig. 6.2-4 Dialog for file selection (when an item definition file is selected) 
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Secondly, read the analysis data file. It is not a problem to read it before reading the item 

definition file. Click “Select” at the right of “Analysis data file” in the dialog shown in Fig. 6.2-4 

and Fig.6.2-5 will appear.  

 

Fig. 6.2-5 Dialog for selecting an analysis data file 

 

The folder that was specified last time is displayed. Search this folder, and select “shape3d_L.dat”. 

Fig. 6 2-6 will appear. 

 

Fig. 6.2-6 Selection of analysis data file “shape3d_L.data” 

 

Click “Open”, and Fig. 6.2-4 will change to Fig. 6.2-7, then click “OK”. 
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Fig. 6.2-7 Dialog for analysis file selection 

 (When item definition file and analysis data file are selected) 

 

Fig. 6.2-1 changes to Fig. 6.2-8. 

 

Fig. 6.2-8 Immediately after a set of sample data is displayed 

 

6.3 Instructions for Mouse Operations and Display Contents6.3 Instructions for Mouse Operations and Display Contents6.3 Instructions for Mouse Operations and Display Contents6.3 Instructions for Mouse Operations and Display Contents    

First, we will explain mouse operation for rotation, zoom and pan. 

Rotation 

Drag the mouse to the right and left or up and down while pressing the left mouse button to 

rotate the displayed contents in three-dimensional space. Dragging right and left rotates the 

display right and left. Dragging up and down rotates it vertically. The pivot point is at the center 

of the displayed content. 

Zoom 

Drag the mouse up and down while pressing the mouse wheel button to zoom in and out on the 

displayed content. To zoom in, drag downwards and to zoom out, drag upwards. 

Pan 

Drag the mouse to the right and left or up and down while pressing the right mouse button to 

pan the displayed content in the direction dragged. 
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By combining these operations, the display shown in Fig. 6.2-8 can be changed to that shown in 

Fig. 6.3-1, which is easier to read. 

 

Fig. 6.3-1 After the sample data view point is changed to make it easier to see 

 

Second, we will explain the display content. In this sample, three spaces are displayed. On the left 

is the space of design variables named “Dimension”, in the center is the space of objective functions 

labeled “Objective functions” and on the right, the space of constraints. The names of “Dimension” 

and “Objective functions” are given in the item definition file. For the “Constraints”, the name 

doesn’t exist in the item definition file and it cannot be changed. There is in fact no analysis data 

called constraints. The design variables and objective functions are shown in the constraint space. 

At the first start-up, the whole display associated with design variables are shown in blue, 

objective functions are shown in brown. Constraint axes and labels are shown in green and points are 

in brown. These colors can be changed independently. Changes are automatically saved as settings 

when the application is closed, the new color setting will be used hereafter.  

In this sample, only two axes are displayed for each space, however, the number of axes to display 

can be increased to three or decreased to one for each space.  

Let’s look at the numbers indicated below the name of the axes. In the example, the (1.0, 9.0) 

below the variable Dx1, which is the X-axis in the dimension space, indicates that the minimum 

value is 1.0 and the maximum value is 9.0. The minimum and the maximum value are automatically 

set from the values of the actual range of the data. 

Now let’s explain point selection with the mouse. Click a point in the objective functions space 

with the left mouse button and the display will change to Fig. 6.3-2. 
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Fig. 6.3-2 Point selection with the mouse 

 

By clicking only one point with the mouse, a set of data points that consist of a point in each space 

and are connected by line segments will be selected. At the same time, the dialog “Display of 

information for selected points” will appear. This dialog is to show numerical data of the point group 

connected by the line segments. You may read the value of each variable in each space. To cancel the 

selection, press Ctrl-Z on the keyboard or select “View ” > “Undo selection” from the menu. The 

display returns to that shown in Fig. 6.3-1. 

In some cases two or more points are highlighted in a space. Fig. 6.3-3 shows one such example. 
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Fig. 6.3-3 When more than two points are selected in a space 

 

In the case, the line segments branch. The dialog “Display of information for selected points” 

cannot present more than two numerical data points, so it will say, “Multiple data exists” instead of 

showing numerical values. 

When you wish to focus on one data point in the dimension space, click the left mouse button on 

the point. The display will be change to Fig. 6.3-4. 
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 Fig. 6.3-4 When the two points are narrowed down into one in Design variables space 

 

Now the number of points is reduced to one, the dialog will indicate the numerical value of the 

dimension. This focusing operation can be canceled by an “Undo” operation, using Ctrl-z, etc. 

When you wish to confirm the numerical values of each of multiple points, before selecting a 

point, you can display them. Click the point you need to confirm using the mouse wheel. The display 

will be that shown in Fig. 6.3-5. 
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Fig. 6.3-5 Temporary selection to confirm numerical data 

 

The selected point is indicated in red and is slightly larger than normal. In the dialog “Display of 

information for selected points”, red color is used to show the numerical data of the point currently 

selected. Similarly, numerical data of any other point can be shown by clicking with the mouse 

wheel. 

 

6.4 Selecting Display Items6.4 Selecting Display Items6.4 Selecting Display Items6.4 Selecting Display Items    

Select “View” > “Select display items” from the menu. Fig. 6.4-1 will pop up. “No item selected” 

means the axis is not shown. For the X-axis and the Y-axis, “No item selected” can also be chosen by 

the user. 

 

Fig. 6.4-1 Dialog to select display items 
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You can select what to show for the three axes of Design variables, Objective functions and 

Constraints. You may also specify the same variable to more than an axis. Change the setting as 

shown in Fig. 6.4-2 and click “OK”. In the case shown, the number of items to display is increased 

to three from two in each space. 

 

Fig. 6.4-2 Changing display items using the dialog 

 

After view-point is adjusted slightly by rotation, etc., the window appears as shown in Fig. 6.4-3. 

 

Fig. 6.4-3 The window after display items are changed 

 

One more space is added because we have added three variables of the dimension space to the 
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constraints. Now all design variables and objective functions are displayed in the figure. 

 

6.5 How to Set Constraints6.5 How to Set Constraints6.5 How to Set Constraints6.5 How to Set Constraints    

The constraints mean the upper and lower limit of each variable for each space. For various 

reasons constraints are imposed on variables and they can be reflected in the display. There are two 

ways to set constraints. One is to set them using dialog operations, the others is to enter them into the 

item definition file. However, only objective functions can have constraints entered directly into the 

item definition file. For the procedure to enter constraints into an item definition file, refer to the 

explanation given in Appendix1. Format of Item Definition File. 

Select “View” > “Select constraints” > “Design variables” from the menu. The dialog to set 

constraints to design variables (Fig. 6.5-1) will pop up. 

 

Fig. 6.5-1 Dialog for setting constraints to design variables (prior to entering constraints) 

 

Here we try to add a constraint to one of the variables in the dialog. For example, when the 

dimension Dx1 must be 5 or less, tick the checkbox of Max. value for Dx1 as shown in Fig. 6.5-2. 

Enter 5.0 as the value and click “OK”. 

 

Fig.6.5-2 Dialog for setting constraints to design variables (after entering constraints) 

 

Fig. 6.4-3 changes to Fig. 6.5-3. 
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Fig. 6.5-3 After a constraint to a design variable is set (Dx1 is 5 or less) 

 

Although it may be difficult to see, in “Dimension” space, the points with Dx1 exceeding 5 

changed color from blue to brown. Since these can be difficult to distinguish, you may change their 

color to a different one. Select “Tools” > “Set color” > “Set basic color of points out of range” from 

the menu. The color setting dialog shown in Fig. 6.5-4 will pop up. The current color: brown, is 

indicated at “Preview”. 
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Fig.6.5-4 Dialog of setting basic color of points out of range (before change) 

 

We change it to purple as shown in Fig. 6.5-5. 

 
Fig.6.5-5 Dialog of setting basic color of points out of range (after change to purple) 

 

At the same time, Fig. 6.5-3 changes to Fig. 6.5-6. Close the dialog of setting basic color of points 

out of range by clicking the close widget in the top right corner of the dialog. 
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Fig. 6.5-6 After changing color of points out of constraint range 

 (where constraint is Dx1 is 5 or less) 

 

Second, set constraints to objective functions. Select “View” > “Select constraints” >“Objective 

functions” from the menu. The dialog to set constraints to objective functions (Fig. 6.5-7) will pop 

up.  

 

Fig. 6.5-7 Dialog for setting constraints to objective functions  

(constraints are as they are set in the item definition file) 

 

For each variable of the dialog, constraint values are already indicated. This is because these 

values have been entered in the item definition file. 

If any one of the values of maximum equivalent stress, total volume or evaluation function of a 

point is out of range of the constraints, the point will be indicated in purple, which means the point is 
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out of constraint range. In this example, total volume; (59.2 to 161.5), is in the range of constraint: (0. 

to 1000.), evaluation function: (1.42e-9 to 0.011), is in the range of constraint: (0. to 1.), but 

maximum equivalent stress: (9.59e7 to 8.75e8), is out of the range of constraint: (0. to 1000.). 

Therefore, it is judged as out of range. However, when maximum equivalent stress is hidden, it is 

judged as within constraints and indicated in navy blue as shown in Fig. 6.5-8. 

 

Fig. 6.5-8 When variables outside the constraints are hidden, points are plotted as within constraints 

 

6.6.6.6.6 How to Set Conditions to hide6 How to Set Conditions to hide6 How to Set Conditions to hide6 How to Set Conditions to hide    

When the points are too crowded to read, you can hide part of them. Select “View” > “Select 

conditions to hide data points” > “Design variables” from the menu. The dialog to set conditions to 

hide design variables (Fig. 6.6-1) will pop up. 

 

Fig. 6.6-1 Dialog for setting conditions to hide design variables (before entering values) 
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The items list is exactly the same as that for constraints. Hiding conditions can be set separately 

from constraints. This will hide points with values outside the maximum value or the minimum 

value. Try to add a condition to hide to one variable in the dialog. For example, take the dimension 

Dx1 and set its hiding condition the same as its constraints. The hiding condition is shown in Fig. 

6.6-2. 

 

Fig. 6.6-2 Dialog to set conditions to hide design variables (after setting) 

 

Click “OK” and Fig. 6.5-6 will change to Fig. 6.6-3. The purple points in dimension space have 

disappeared. 

 

Fig. 6.6-3 After setting a hiding condition to a design variable  

(display only points with Dx1 equal to 5 or less) 
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As above, set hiding conditions to objective functions. Select “View” > “Select conditions to hide 

data points” > “Objective functions” from the menu. The dialog to set hiding conditions to objective 

functions (Fig. 6.6-4) will pop up. 

 

Fig. 6.6-4 Dialog to set hiding conditions to objective functions (before entering conditions) 

 

Set the maximum value of evaluation function to 0.005 as shown in Fig. 6.6-5. 

 
Fig. 6.6-5 Dialog to set hiding conditions to objective functions  

(after setting the max. value of the evaluation function to 0.005) 

 

Click “OK” and the points with evaluation function exceeding 0.005 will disappear as shown in 

Fig. 6.6-6. 
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Fig. 6.6-6 After setting a hiding condition to an objective function 

 (condition: evaluation function is 0.005 or less) 

 

6.7 How to Use Favorites6.7 How to Use Favorites6.7 How to Use Favorites6.7 How to Use Favorites    

This capability is to remember data of a set of selected points connected with line segments and to 

save it in a file. We call these memorized data “Favorites”. This means you can register the data to 

“Favorites” when you find it optimal or close to optimal. Obviously you can add multiple sets of 

data to “Favorites”. 

Fig. 6.7-1 shows an example of a set of selected points. 
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Fig. 6.7-1 Example of a set of selected points 

 

Here we selected a set of data that has rather small values for both the maximum equivalent stress 

and total volume. Select “Favorites” > “Add” from the menu. The set of data connected by line 

segments is registered to “Favorites”. However, as it is not known whether it has been actually 

registered to “Favorites”, we confirm it by manually saving the “Favorites” to a file. Select “File” > 

“Save Favorite” from the menu and the dialog shown in Fig. 6.7-2 will pop up. 

 

Fig. 6.7-2 Specifying a file to save the favorites to(before a file is given) 
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Give a file name “myFavorite1.dat” as shown in Fig. 6.7-3. The extension will not be added 

automatically. 

 
Fig. 6.7-3 Specifying a file to save the favorites to (after a file is given) 

 

“Favorites” are saved in the same format as the analysis data file. If it is opened by a text editor, it 

will appear as shown in Table. 6.7-1. The sets of selected data are contained there. For the data 

format, refer to Appendix2. Format of Analysis Data File. 

 

Table 6.7-1 Content of the favorites file: myFavorite1.dat. 

1,6 

1,1 

1.0,4.993190685992449,2.337874454658954,1.78944E8,88.77557,2.53543988713966E-7 

Let’s now add one more set of data shown in Fig. 6.7-4 to our “Favorites” 
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Fig. 6.7-4 Example of another set of selected data 

 

This time save it as “myFavorite2.dat”. The content of the file is as shown in Table 6.7-2. 

 

Table 6.7-2 Content of the favorites: myFavorite2.dat 

2,6 

1,1 

1.0,4.993190685992449,2.337874454658954,1.78944E8,88.77557,2.53543988713966E-7 

2,1 

2.123095495887821,8.513022361209854,2.58481186665241,3.273848E8,69.103718,6.562331325

161739E-9 

 

You can see the data has increased to two blocks. In this manner, you can add as many sets of data 

to “Favorites” as you like. 

Favorites can also be deleted. Select “Favorites” > “Clear” from the menu. All the registered 

favorites are deleted. In this case, you can still save “Favorites”. However, the created file will have 

no data in it. 

The saved “Favorites” data can be visualized. Start up this application. For the box of “Item 

definition file”, select the one used when you saved “Favorites”, and for “Analysis data file”, select 

one of the saved “Favorites” file. Fig. 6.7-5 shows an example in which we read “myFavorite2.dat” 

as a “Favorites” file, and select a secondly added favorite data. 
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Fig. 6.7-5 How a “Favorites” file “myFavorite2.dat” looks  
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7. Instructions for Other Functions7. Instructions for Other Functions7. Instructions for Other Functions7. Instructions for Other Functions    

7.1 Closing 7.1 Closing 7.1 Closing 7.1 Closing ＴＴＴＴhe Applicationhe Applicationhe Applicationhe Application    

“File” > “Exit” 

When the application is closed, user's settings will automatically be saved to two types of 

cache files. One contains the settings inherent to the combination of a selected “Item 

definition file” and an “Analysis data file” as follows: 

(i) Display items 

(ii) Constraints 

(iii) Conditions to hide items 

(iv) Use of logarithmic scale 

User's settings to save depend on the data contents. The exact name of the folder to save the 

cache file to varies by OS. In the case of Windows XP, it is "C:\ Documents and Settings\user 

name\Local Settings\Temp\ADVENTURE_DecisionMaker". The name of the saved file is the 

names of the analysis data file and the item definition file combined with an “@”. 

The aim is to avoid losing the user's preferences about display items and constraints when 

the application is closed. When the data has many spaces it is quite difficult to exactly 

reproduce user's preferences. This capability is therefore very helpful. Be aware that the file 

cannot be edited. 

The other cache file contains settings that do not depend on which “Item definition file” or 

“Analysis data file” users have chosen. They include: 

(i)  Font settings 

(ii)  Color settings 

(iii) Line attribute settings 

This cache file is saved into the folder of software installation. The file name is 

“settings.config”. Be aware that this file cannot be edited either. 

 

7.2 Use of Logarithmic Scale7.2 Use of Logarithmic Scale7.2 Use of Logarithmic Scale7.2 Use of Logarithmic Scale    

“View” > “Display logarithmic scale”  

When the data range is wide and its order of magnitude varies greatly, you can display axes 

with a logarithmic scale for easier viewing. Select the menu as above and the window in Fig. 

7.2-1 will pop up. 

 

Fig. 7.2-1 Dialog to set use of logarithmic scale 
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The default scale of each axis is linear. To change to a logarithmic scale, tick the 

“logarithmic scale” box to the right of the relevant axis label and click “OK”. A value of 

1.0E-6 contained in the box indicates the default minimum value when logarithmic scale is 

used. If the minimum value of the actual data for each axis is zero, it will be infinitesimal on 

the logarithmic scale and causes problems. Therefore a positive decimal figure close to zero 

must be used as the minimum value. Fig. 7.2-2 shows an example before the logarithmic scale 

is used.  

 

Fig. 7.2-2 Before using the logarithmic scale for Max. equivalent stress 

 

Fig. 7.2-3 shows how data looks after a horizontal axis of the maximum equivalent stress is 

plotted by the logarithmic scale. 
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Fig. 7.2-3 After Max. equivalent stress is displayed in logarithmic scale 

 

Note the data has shifted to the right. 

 

7.3 Restoring Viewpoint to the Default Position7.3 Restoring Viewpoint to the Default Position7.3 Restoring Viewpoint to the Default Position7.3 Restoring Viewpoint to the Default Position    

“View” > “Reset viewpoint to default”  

This function is what the menu name indicates. It is useful when you wish to have the front 

view. 

 

7.4 Hiding Points Not Selected7.4 Hiding Points Not Selected7.4 Hiding Points Not Selected7.4 Hiding Points Not Selected    

“View” > “Hide points not selected”  

Use this function when there are too many data points to see. As shown in Fig. 7.4-1, 

suppose a set of data points is selected. 
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Fig. 7.4-1 The way data looks when a set of points is selected 

 

When the function is checked, the display changes as shown in Fig. 7.4-2. The points that 

are not selected will be hidden. 

 
Fig.7.4-2 When the points not selected are hidden 
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If you select the same menu again, it returns to the state as shown in Fig. 7.4-1. This on-off 

operation can also be executed by pressing Ctrl-N. 

 

7.5 Hiding Lines7.5 Hiding Lines7.5 Hiding Lines7.5 Hiding Lines    

“View” > “Hide lines” 

As shown in Fig. 6.3-3 there are cases where more than two points are selected in a space. If 

only two points are selected there is no problem, however, when dozens are selected, there 

may be too many lines to see data clearly. In such cases use this function. Fig. 7.5-1 shows 

how data looks when the number of axes was increased from that shown in Fig. 6.3-3 while 

keeping point selection the same. 

 

 

Fig. 7.5-1 When lines are displayed 

 

When the menu item is selected, lines are hidden and the selected points remain highlighted 

in aqua and red as shown in Fig. 7.5-2. 
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Fig. 7.5-2 When lines are hidden (selected points are highlighted) 

 

This function will be of more use when used in conjunction with the 7.4 Hiding Points Not 7.4 Hiding Points Not 7.4 Hiding Points Not 7.4 Hiding Points Not 

SelectedSelectedSelectedSelected function. If you hide the points that are not selected, data presentation changes as 

shown in Fig. 7.5-3. The set of selected points will be indicated clearly. 
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Fig. 7.5-3 When lines and points not selected are hidden 

 

This on-off operation can also be executed by Ctrl-L. 

 

7.6 Undo Selection7.6 Undo Selection7.6 Undo Selection7.6 Undo Selection    

“View” > “Undo selection” 

A Ctrl-Z press on the keyboard provides the same capability as this menu item. 

 

7.7 Checking Duplication7.7 Checking Duplication7.7 Checking Duplication7.7 Checking Duplication    

“Tools” > “Check duplication” 

This function checks if there are any duplicate lines in a data file. If there are, the dialog as 

shown in Fig. 7.7-1 will pop up. 

 
Fig. 7.7-1 Warning display when there is duplication in the data 

 

This means that the data of the 248th line of the first block and the 313th line of the first 

block is the same. 

When there is no duplication, the dialog shown in Fig. 7.7-2 will pop up. 
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Fig. 7.7-2 When there is no duplication in the data 

 

7.8 Setting Font7.8 Setting Font7.8 Setting Font7.8 Setting Font    

“Tools”> “Set font” 

Fonts of labels and values can be changed. Select this menu item, and the dialog shown in 

Fig. 7.8-1 will pop up. 

 
Fig. 7.8-1 Dialog for font setting 

 

 “Dialog” is the name of the font currently in use. The size can be change by “Size” - 1 is 

the smallest value. Tick the box for “Bold” to make render the font in bold. For Italics, tick the 

box for “Italic”. When you re-open the dialog, you must set these values again since the 

previous settings are not memorized. When you choose “Times New Roman”, the window 

will look as shown in Fig. 7.8-2. 
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Fig. 7.8-2 When “Times New Roman” is selected 

 

7.9 Setting Color7.9 Setting Color7.9 Setting Color7.9 Setting Color    

The colors of points, lines and axes can be changed. 

“Tools” > “Set color” > “Set basic color of points in range” 

This operation sets the color of points within the constraint range. The default is navy 

blue: . The dialog for color settings as shown in Fig. 7.9-1 will pop up. In the “Preview” 

block, the current color navy blue is painted. 
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Fig. 7.9-1 Dialog to set basic color of points within range (before change) 

 

We change it to viridian as shown in Fig. 7.9-2.  

 

Fig. 7.9-2 Dialog to set basic color of points within range (after change to viridian) 

 

The data view window changes as shown in Fig. 7.9-3. 
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Fig. 7.9-3 After changing color for within range of constraint 

 

“Tools” > “Set color” > “Set basic color of points out of range” 

This sets the color of points outside the constraint range. The default is brown. Operation is 

the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > ”Set color of selected points in range” 

This sets the color of selected points within the constraint range. The default is aqua. 

Operation is the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set color of selected points out of range” 

This sets the color of selected points that are out of constraint range. The default is magenta. 

Operation is the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > ”Set color of lines in range (U)” 

This sets the color of the line segments connecting selected points that are within the 

constraint range. The default is navy blue. If even one of the connected points is outside the 

range, all the associated line segments are drawn in the color used for lines out of range. 

Operation is the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set color of lines out of range” 

This sets the color of the line segments connecting selected points that are outside the 

constraint range. The default is brown. If even one of the connected points is outside the range, 

all the associated line segments are drawn in the color used for lines out of range. Operation is 
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the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set color of lines with multiple data” 

This sets the color of the line segments connecting selected points such that two or more 

points are selected in a space as explained in 6.3 Instructions for Mouse Operations and 6.3 Instructions for Mouse Operations and 6.3 Instructions for Mouse Operations and 6.3 Instructions for Mouse Operations and 

Display ContentsDisplay ContentsDisplay ContentsDisplay Contents. The default is purple: . If even one of the connected points is outside the 

range, all the associated line segments are drawn in the color used for lines out of constraint 

range. Operation is the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set axes color for design variables” 

This sets the axes color for design variables. The default is navy blue: . Operation is the 

same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set color of space boundary lines for design variables” 

This sets the color of space boundary lines for design variables. The default is pale purple. 

Operation is the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set axes color of objective functions” 

This sets the axes color for objective functions. The default color is brown. Operation is the 

same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set color of space boundary lines for objective functions (K)” 

This sets the color of space boundary lines for objective functions. The default is pale pink. 

Operation is the same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set axes color for constraints” 

This sets the axes color for constraints. The default is green. Operating procedure is the 

same as that for the color setting of points within constraint range. 

 

“Tools” > “Set color” > “Set color of space boundary lines for constraints” 

This sets the color of space boundary lines for constraints. The default is pale green. 

Operation is the same as that for the color setting of points within constraint range. 

 

7.10 Setting Line Attributes7.10 Setting Line Attributes7.10 Setting Line Attributes7.10 Setting Line Attributes    

“Tools” > “Set line attributes” > ”Set line attributes of selected data points” 

The line attributes of line segments connecting selected data points can be set. The dialog 

shown in Fig. 7.10-1 will pop up. 
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Fig. 7.10-1 Dialog to set attributes of line segments connecting selected data points 

 

This sets line width, line type and switches anti-aliasing on and off. Anti-aliasing means 

making jagged lines smoother. Fig. 7.10-2 shows how the default line attributes look. 

 

Fig. 7.10-2 Default line attributes of line segments connecting selected data points 

 

Fig. 7.10.-3 shows how the main window looks when the line width is changed to 3. 
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Fig. 7.10-3 When width of line segments is changed to a value of 3 

 

“Tools” > “Set line attributes” > “Set line attributes of axes” 

This sets line attributes of axes. The dialog shown in Fig. 7.10-4 will pop up. The attribute 

types to set and how to set attributes are the same as those for the attributes of line segments 

connecting selected data points. 

 

Fig. 7.10-4 Dialog to set line attributes of axes 

 

“Tools” > “Set line attributes” > “Set line attributes of space frames” 

This sets the line attributes of space frames. Fig. 7.10-5 will pop up. The attribute types to 

set and how to set attributes are the same as those for the attributes of line segments 

connecting selected data points. 
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Fig. 7.10-5 Dialog to set line attributes of space frame 

 

When “Dashed line 2” is selected for the space frames, the display will be changed as 

shown in Fig. 7.10-6. 

 

Fig. 7.10-6 When “Dashed line 2” is selected as the line type of the space frame  

by the line attribute dialog 

 

7.11 Product Information7.11 Product Information7.11 Product Information7.11 Product Information    

“Help” > “About the product” 

The data for name, version, build number, and copyright of this module etc. is shown as in 

Fig. 7.11-1. 
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Fig. 7.11-1 Presentation of product information 
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8. Sample Files8. Sample Files8. Sample Files8. Sample Files    

Sample files may be found in the folder “samples” under the folder ADVENTURE DecisionMaker 

is installed into. Table 8-1 is the sample file list. 

Table 8-1 Sample files 

File Name Explanation 

dogDefinition_en.def An item definition file for characteristics of various dog types 

dog.csv An analysis data file for the characteristics of various dog 

types: should be used with dogDefinition_en.def as a set 

opt_en.def An item definition file for data of shape optimization for a 

structural part 

shape3d_L.dat An analysis data file for data of shape optimization of a 

structural part: should be used with opt_en.def as a set 

shape3d_LwoD.dat An analysis data file for data of shape optimization of a 

structural part (duplicate data is eliminated): should be used 

with opt_en.def as a set 

 

8.1 Characteristics Data of Varied Dog8.1 Characteristics Data of Varied Dog8.1 Characteristics Data of Varied Dog8.1 Characteristics Data of Varied Dog Types Types Types Types    

This sample is of characteristics data for various dog types. We have taken an example familiar to 

us. As the design parameter, price is selected. Objective functions include the following items. Nose 

length (1 to 5), leg length (1 to 5), hair length (1 to 5) and size (1 to 5) are in a space called “looks”. 

Walk frequency (1 to 14 times per week), shampoo frequency (1 to 4times per month), and brushing 

frequency (1 to 7 times per week) are in a space called “care”. Docility (1 to 5) and lickyness 

(frequency of licking - 1 to 5) are in a space called “temperament”. Smell (1 to 5) and amount of 

barking (1 to 5) are in a space called “environment”. Meal amount (1 to 5) and trimming frequency 

(1 to 12 times / year) are in a space called “cost”. The actual data is as shown in Table 8.1-1. 

Table 8.1-1 Example of the characteristics data for various dog types 
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Miniature 

dachshund 

(long) 100000 5 1 3 7 1 3 4 5 3 5 2 2 4
Toy poodle 120000 2 3 5 14 2 7 5 3 3 3 3 2 12
Beagle 80000 4 4 1 21 3 3 5 3 5 5 2 3 1
Shih-tzu 89000 1 2 5 14 2 7 4 3 3 5 2 2 6
Shiba 60000 4 4 2 14 1 2 3 3 3 3 4 4 3  

 

8.2 Data of Calculation Result for Parametric Optimization8.2 Data of Calculation Result for Parametric Optimization8.2 Data of Calculation Result for Parametric Optimization8.2 Data of Calculation Result for Parametric Optimization    

This is the result of calculation of an example attached to ADVENTURE_Opt Ver. 0.1b. 

“shape3d_L” of Real GA (real value Genetic Algorithm) is actually selected from the examples. The 
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problem's geometry is as shown in Fig. 8.2-1 

 

Fig. 8.2-1 Geometry of parametric optimization analysis 

 

Design parameters are Dx1, Dx2 and Dy1. Initial values are all 1.0. Boundary conditions restrain 

displacement in each direction on face number 3 (at Dx2) and apply a load of 1.5 per unit area in the 

negative Y-direction (downward) on face number 8 (upper right, on the vertical edge) as shown in 

Fig. 8.2-2.  
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Fig. 8.2-2 Figure showing face numbers 

 

Fig. 8.2-3 shows the equivalent stress distribution and deformed geometry at initial parameter 

values. The maximum equivalent stress value is 8.75e8. 
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Fig. 8.2-3 Deformed geometry and equivalent stress distribution at initial parameter values 

 

As described above, Dx1, Dx2 and Dy1 are taken as design parameters in this sample. As 

objective functions, maximum equivalent stress, total volume and an evaluation function are chosen. 
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9. Log and Work Folders9. Log and Work Folders9. Log and Work Folders9. Log and Work Folders    

9.1 Log9.1 Log9.1 Log9.1 Log    

This module would not normally output a log. If you need a log report for a bug, edit the following 

two lines in the file “ADVENTURE_DecisionMakerV1_0.1ax” in the folder where the module is 

installed.  

lax.stderr.redirect= 

lax.stdout.redirect= 

Change the above lines as follows: 

lax.stderr.redirect=console 

lax.stdout.redirect=console 

 

After saving the “.lax” file, start the module in the normal way, a “command prompt” window will 

appear containing the log. Caution: When you shut down this module, the “command prompt” will 

disappear. If you designate a specific filename instead of “console”, the “command prompt” window 

will not appear and log will be recorded in the file. Be sure to use two consecutive \ symbols as a 

separator for each folder name as in the following example: C:\\tmp\\advDecisionMaker1_0.log 

 

9.2 Work Folders9.2 Work Folders9.2 Work Folders9.2 Work Folders    

If your OS is Windows 2000 Professional, the cache file will be created or updated automatically 

in “C:\Documents and Settings\Your user name\Local 

Settings\Temp\ ADVENTURE_DecisionMaker\” when you close this module. 

This module can be executed even if the files in this folder are deleted. In such a case, be aware 

that the setting values, which are associated with data files and was written in the cache file, will no 

linger be available. 
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10. Modifi10. Modifi10. Modifi10. Modification of the Maximum Value for Heap Memorycation of the Maximum Value for Heap Memorycation of the Maximum Value for Heap Memorycation of the Maximum Value for Heap Memory    

Depending on the scale of the analysis data files being analyzed, heap memory for the module may 

be exhausted. In such a situation, the program will stop responding. If you can access the log of the 

module by the procedure described in chapter 9, the following will be seen on the last line. 

java.lang.OutOfMemoryError 

Edit the following lines in ADVENTURE_DecisionMakerV1_0.lax to increase the initial value and 

the maximum value of the heap memory. The default is 128Mbytes and 512Mbytes, respectively. 

# LAX.NL.JAVA.OPTION.JAVA.HEAP.SIZE.INITIAL 

# ----------------------------------------- 

# Initial heap memory 

 

lax.nl.java.option.java.heap.size.initial=128M 

 

# LAX.NL.JAVA.OPTION.JAVA.HEAP.SIZE.MAX 

# ------------------------------------- 

# max heap memory 

 

lax.nl.java.option.java.heap.size.max=512M 
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11. Uninstalling Procedure11. Uninstalling Procedure11. Uninstalling Procedure11. Uninstalling Procedure    

Select the “Control Panel” from the “Start Menu” on Windows, and then “Add or Remove 

Programs” (on Windows 2000, “Start” > “Settings” > “Control Panel”). Select 

“ADVENTURE_DecisionMakerVer1_0” from the list of installed programs, then click the 

“Change/Remove” button. Fig. 11-1 will appear, and click “Uninstall” (Fig. 11-2). After completion 

of uninstallation, the window shown in Fig. 11-3 will appear. Click “Done”. 

 

Fig. 11-1 Start of uninstallation 

 

 

Fig. 11-2 During uninstallation 
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Fig. 13-3 Uninstallation complete 
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Appendix1. Format of Item Definition FileAppendix1. Format of Item Definition FileAppendix1. Format of Item Definition FileAppendix1. Format of Item Definition File    

 

A1.1 Basic StructureA1.1 Basic StructureA1.1 Basic StructureA1.1 Basic Structure    

Definition of items has a hierarchical structure as shown in Table A1.1-1. 

 

A1.1-1 Hierarchical structure of item definition 

+- Design variables

|    +- Variable space #1

|     |          +- Item #1

|    +- Variable space #2

|     |          +- Item #2

|     |          +- Item #3

|    +- Variable space #3

|     |          +- Item #4

|     |          +- Item #5

|     |        +- Constraint(lower limit)

|     |          +- Item #6

|     |                 +- Constraint(upper limit)

……

+- Objective functions

|    +- Objective function space #1

|     |          +- Item #1

|     |                 +- Constraint(upper limit)

|    +- Objective function space #2

|     |          +- Item #2

|     |                 +- Constraint(lower limit)

|     |          +- Item #3

|     |                 +- Constraint(upper limit)

|     |                 +- Constraint(lower limit)

|     |          +- Item #4

|     |                 +- Constraint(upper limit)

……
 

 

A1.2 ExampleA1.2 ExampleA1.2 ExampleA1.2 Example    

Table A1.2-1 shows an example of item definition. This is attached as opt_en.def in the samples 

folder. 

 

Table A1.2-1 An example of item definition 

# definition of a space for design variables 

variables = space1 

variables.space1.name = dimension 

variables.space1.member = dx1, dy1, dx2 

 

# definition of an item of design variables 

variables.dx1.name = Dx1(X-direction) 

variables.dx1.abbrev = Dx1 

variables.dx1.column = 1 
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variables.dy1.name = Dy1(Y-direction) 

variables.dy1.abbrev = Dy1 

variables.dy1.column = 2 

 

variables.dx2.name = Dx2(X-direction) 

variables.dx2.abbrev = Dx2 

variables.dx2.column = 3 

 

# definition of a space for objective functions 

target = space1 

target.space1.name = object functions 

target.space1.member = maxEquivStress, totalVolume, evalFunction 

 

# definition of items of objective functions 

target.maxEquivStress.name = Max. equivalent stress 

target.maxEquivStress.abbrev = Max. equivalent stress 

target.maxEquivStress.column = 4 

target.maxEquivStress.const.min = 0 

target.maxEquivStress.const.max = 1000 

 

target.totalVolume.name = Total volume 

target.totalVolume.abbrev = Total volume 

target.totalVolume.column = 5 

target.totalVolume.const.min = 0 

target.totalVolume.const.max = 1000 

 

target.evalFunction.name = Evaluation function 

target.evalFunction.abbrev = Evaluation function 

target.evalFunction.column = 6 

target.evalFunction.const.min = 0 

target.evalFunction.const.max = 1 

 

# Constraint space is a copy of the objective function space in the current implementation 

 

The followings are explanations of keywords. The values of keywords are presented as key=value. 

By connecting keywords by a period, a hierarchical structure is expressed. 

 

(1)Overall 

variables :Indicates design variables. Only used at the top level. Value for this key is a list of 

character strings that identify spaces delimited by commas. 

target :Indicates objective functions. It can be used only at the top level. Value for this key is 

a list of character strings that identify spaces delimited by commas. 

 

(2)Both for spaces and items 

name :Indicates space or item name. It can be used only at the lowest level. Japanese 
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character strings are also allowed under the Windows environment. 

 

(3)Space 

member :Indicates item names in each space (required). It can be used only at the lowest level. 

Value for this key is a list of character strings that identify items included in spaces 

and delimited by commas. 

 

(4)Item 

abbrev :Character strings for abbreviation of item names (required). It can be used only at the 

lowest level. Japanese character strings are allowed under the Windows environment. 

column :An integer to show the field number of this item in a corresponding analysis data file 

(required). It can be used only at the lowest level. 

const.min :Indicates the minimum value of a constraint. It can be used only at the lowest level. 

Enter a decimal number when you set one. Place "null" when you do not set one. 

When no definition exists, it is interpreted as "null". 

const.max :Indicates the maximum value of a constraint. It can be used only at the lowest level. 

Enter a decimal number value when you set one. Place "null" when you do not set one. 

When no definition exists, it is interpreted as "null". 
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Table A2-1 shows an example of an analysis data file. This example is attached as dog.csv in the 

samples folder. 

 

Table A2-1 An example of an analysis data file 

1,14 

1,5 

100000,5,1,3,7,1,3,4,5,3,5,2,2,4 

120000,2,3,5,14,2,7,5,3,3,3,3,2,12 

80000,4,4,1,21,3,3,5,3,5,5,2,3,1 

89000,1,2,5,14,2,7,4,3,3,5,2,2,6 

60000,4,4,2,14,1,2,3,3,3,3,4,4,3 

 

The following is the explanation of the format. 

The 1st line 

total number of blocks, number of items per line 

The 2nd line (the head of the first block) 

block ID, total number of lines in the 1st block 

Follow data of total number of lines in the 1st block 

each line consists of comma-separated items 

 

In Table A2-1, the number of total blocks is one, and the number of items per line is 14. The ID of 

the first block is 1, and the total number of lines in the first block is 5. Block ID starts not from 0 but 

1. The next five lines give the individual data. Each line has 14 items delimited by a comma. 

    


